Plumbing issue - at wits end

Alfredo De La Fe

Senior Member
Rating - 100%
29   0   0
Location
Upper West Side
Helping my buddy set up his tank. Everything is up and running, but the return hose is leaking where it goes into the sump. Finally got it to stop leaking from the hose connected to the bulkhead under the tank...

I only have one hose clamp. Had to cut the end of the hose off but the hose is on TIGHT. Suggestions?



Sent from my SM-N900P using Tapatalk
 

lnevo

Active member
Rating - 100%
106   0   0
Location
Bellmore, NY
You can buy a replacement hose cuff it's called if I remember correct then cut the hose to length. The new cuff basically screws onto the ribs of the hose.
 

Alfredo De La Fe

Senior Member
Rating - 100%
29   0   0
Location
Upper West Side
Where can I buy a hose cuff? I plan on going to Home Depot/Lowes on my way to Reefapalooza to see if I can find a piece of hose with the braided string that is the right diameter. Also will pick up some plastic hose clamps.
 

lnevo

Active member
Rating - 100%
106   0   0
Location
Bellmore, NY
I had to order it online. A pool supply store may have it. The problem is, the hose I'm using and probably yours is a bit smaller than the standard size so it's not as easy to find.
 

Alfredo De La Fe

Senior Member
Rating - 100%
29   0   0
Location
Upper West Side
Yeah, that is another problem. Hopefully I find something at Lowes/Home Depot... Tank is almost set up. Just need to resolve this leak, tweak his skimmer then he can have fun aquascaping!

Sent from my SM-N900P using Tapatalk
 

Featured Sponsors


Top