Sand buildup in the sump??

AquaDan

New member
Rating - 100%
12   0   0
Location
NJ
I've been cycling my tank for about a week now. Today I noticed some buildup in the drain chamber of my sump. It was on the bottom and on the skimmer's pump. I shook the skimmer around and all these particles started floating through the chambers of the sump and into the display tank. I'm pretty sure its sand and I noticed some on the bottom of the overflow boxes too. Is this normal? I'm wondering why this stuff was not caught by my filter socks.

FYI: My skimmer has been off while in cycle.

Thanks.
 

KathyC

Moderator
Rating - 100%
200   0   0
Location
Barnum Island
Try removing the sand with a turkey baster and see if more appears, if so, your filter sock may either be overflowing, or have a leak in it.
Could the sand have been there from the initial set up (pre filter sock) and you are just noticing it now?
 

AquaDan

New member
Rating - 100%
12   0   0
Location
NJ
Try removing the sand with a turkey baster and see if more appears, if so, your filter sock may either be overflowing, or have a leak in it.
Could the sand have been there from the initial set up (pre filter sock) and you are just noticing it now?
Thanks Kathy. Its entirely possible that it was there pre-filter sock. I just changed the socks. Are you supposed to change socks during cycle? Just took some pics also.
 

Attachments

AquaDan

New member
Rating - 100%
12   0   0
Location
NJ
Mine does the exact same thing I just live with it. Maybe eventually i will suck it up as suggested but whatever. I have fiji pink sand so is pretty fine.
I'm using Fiji Pink also. I guess I'll try and remove it like Kathy suggested. Thanks for the feedback.
 

Featured Sponsors


Top